Skip to main content

No network on Fedora 9 x86_64 follow up

Following my post related to NetworkManager. I have found out about the workaround. If you have x86_64 system with 4GB support enabled, you should disable it in order to make NetworkManager work. I am not sure if that bug affects other distributions so, possibly the bug may be related to the x86_64 kernel. Let see if my theory can be verified.

Comments

Eugene said…
That's strange. I am using Fedora 9 x86_64 with 4GB RAM, and I don't have any problem with NetworkManager.
Anonymous said…
same here.

Currently using x86_64 with 4gb + networkmanager. No such issues.

Its a Thinkpad T61 with Intel 3945ABG wireless
Further investigation, it appears the bug is more kernel related than NetworkManager with the use of skge module. My system uses Marvell Yukon Ethernet integrated in the Gigabyte GA-K8NSC-939. Maybe the skge module does not support 4GB so I have submitted the bug for that reason.
Jiggy said…
I had the exact same problem with very similar hardware. Your post helped me get some ideas, I tried a bunch of different things. Did some packetsniffing etc.

Turns out it is something specific to the Marvell network card. I have two NICs on my motherboard and I tried the other one (Nvidia) and network seems to work perfectly! So maybe your problem could be fixed/worked around by trying a different network card.
I took an old Dlink Ethernet card, enabled 4GB RAM support on the motherboard and now runs Fedora 9. The issue related to Marvell network card about the 4GB RAM is confirmed thus definitely a kernel bug.
Anonymous said…
Fedora 9 x86_64 - The network icon next to my name and date always shows that there is no network available, and I usually have to manually restart networking a few times, click on the icon and enable and disable networking a few times, as well as fiddle with "work offline" back and forth in my Firefox browser. Sometimes it starts working quickly, other times I have to play with it for 10 minutes before I can reach the internet. Regardless, the icon always shows up as disconnected even if I am able to access the network. A search of the internet has not assisted me in my quest to resolve the issue. Can anyone help?
Could you provide your Ethernet card specification?
Anonymous said…
Good work people. I have a GA-K8NSC-939 + Athlon 3200+ and 4GB. I'm running Ubuntu 8.04 wuth an updated 2.6.24-17 64-bit kernel. I see the same problem.
When I upgraded from 2GB to 4GB, I went into the BIOS, Ctrl-F1 to get to the advanced chipset features, then enabled 4G RAM support. After that, when I booted I couldn't access the network. Interestingly, there was a boot-time message from the kernel
skge eth1: enabling interface
, so I didn't look there for the problem.


After reading the posts here I went back, disabled 4G support and got my network back - at the cost of a few hundred MB of RAM. The kernel now only sees 3584MB instead of the 4096MB it saw before.


Pete

Popular posts from this blog

Detailing the installation of AMD OpenCL rpm for Fedora

Revisiting the previous blog and freshly reinstalling Fedora Design Suite due to a busted boot, I look at the official guideline from AMD Driver for Red Hat Enterprise Linux 7.2 and write a way to improve the process of installing on Fedora 29 in this example. Extracting the tarball contains the following: amdgpu-install amdgpu-pro-install symlink to amdgpu doc folder repodata folder RPMS folder containing rpm package Executing the command ./amdgpu-install -opencl=pal --headless sadly failed on Fedora on that line: ./amdgpu-install -y --opencl=pal --headless Last metadata expiration check: 0:30:51 ago on Mon 19 Nov 2018 07:13:43 PM PST. No match for argument: amdgpu Upon closer look, the script failed to created a temporary repository on /var/opt/amdgpu-pro-local probably explaining why amdgpu metapackage name failed to display. Someone should investigate and provide a fix. At least, we find out Fedora support is available but unofficial. Due to its design, Gnome

Getting ready for Vanlug

Busy weekend. I just took a break for making a presentation of Fedora Core 6 and Fedora Project for Vancouver Linux Users Group which will debut on November 20, 2006. A local computer store was kind enough to give me a laptop for the demonstration of Fedora Core 6 (Zod) live spin and Sugar interface from OLPC Project. Should you be interested to view that event and live near Vancouver, here is the address .

Using AMD RX Vega driver OpenCL on Fedora 29

The Raven Ridge APU is very capable processor to handle OpenCL inside some applications like Blender, Darktable and Gimp. Unfortunately, the current implementation from Mesa, clover, stuck to 1.3, is not supported. AMD released their driver 18.40 with OpenCL2.0+ targeting only Red Hat Enterprise Linux/Cent OS 6.10 and 7.5 in addition of Ubuntu LTS. The good new is the former rpm format can be used on Fedora. The graphical part of Raven Ridge is Vega 8, basically a cut-down of Vega56 or Vega64 meaning choosing either driver for RX Vega . The instruction is provided for extracting the rpm files but here is  some requirements for OpenCL: kernel-devel (provided by Fedora repository) amdgpu-dkms dkms libopencl-amdgpu-pro opencl-amdgpu-pro-icd Once done, applications needing OpenCL will automatically detect the driver located on /opt/amdgpu/lib64 . Blender will list as unknown AMD GPU and Darktable will enable it. OpenCL from official AMD driver enabled on Darktable Ra